v2.1.2

 - use 2.1 API version
 - fix usage of 'cuda_root' option